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Tutorial 6: A Spoon Holder

Overview
In this tutorial, we use the SurfaceWorks-
SolidWorks combination to create a spoon holder
— one you might keep on your stove while
cooking (see figure at right). The key here is
change: the model is constructed so that
everything can be adjusted until the optimal
design is achieved.

Entity introductions:

➢ None

Concept and Function introductions:

➢ For nicely rounded ends, make last 2 control points perpendicular to end
➢ Select>Current Layer Filter
➢ Use a single curve in various forms as the lofting curves for lofted surfaces to

guarantee that the curves all have the same parametric velocity resulting in a
smoother surface shape

The basic steps:

• We begin with a .SLDPRT model composed of the planes and a sketch that will
generate the spoon holder surface.

• In SurfaceWorks, we construct the supports for three surfaces, building in
relationships that allow great freedom in refining the shape of the spoon holder.
We then stitch the three surfaces together so they will be transferred into
SolidWorks as a solid.

• In SolidWorks, we cut a shape to the side profile, cut a flat bottom, then shell the
imported solid.

• Returning to SurfaceWorks, we make the final design refinements.
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Adding SurfaceWorks Parents
1 Start SolidWorks and Open SpoonHolderStart.sldprt from \Integrated

Tutorials.

2 Save this file as SpoonHolder.sldprt

'Sketch1', 'Plane4', 'Plane5' and 'Plane6' have already been added as SurfaceWorks
parents.

3 In the FeatureManager, click on each of them and note what they look like in the
model  Sketch1 is a line that lies in Plane6; Plane6 is at an angle from the
horizontal; Plane4 and Plane5 are perpendicular to Plane6.

4 Choose SurfaceWorks>Modeler.

Check program settings
Let’s check those program settings and make sure we’re all starting with the same
ones (the initial program defaults). This is what you should have:

On the View menu:

Status Bar should be ON (preceded by a checkmark; to turn an option on,
simply click on the menu item or if it has a box next to it click on the box).

All Toolbars should be ON.  To check this, click on Toolbars.  The resulting list
should have all of its boxes checked.

On the Tools>Options, General, tab:

Rotation Constraint should be set to Free tumble

On the Tools>Options, Dragging tab:

All the snaps should be ON

Prompt after drag should be OFF (no checkmark)

On the Tools>Options, Performance tab, under Display Controls:

Set Degrees per keystroke to 10

On the Tools>Options, Entity tab, under Quick Spline Defaults:

Click the B-spline radio button

Set Degree to 3

Click the Alternate spline creation check box.

Make the Initial Control Curve
What you see here in SurfaceWorks are the SolidWorks planes and the endpoints of
the line  since we won’t be needing it, we’ve already hidden the line.
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1 Switch to the Right view  and  or <F> to Zoom to Fit.

2  (or <G> or View>Grid) to toggle the grid on.

3 Turn on Point Nametags .

We are going to insert a B-spline Curve using Quick Spline Mode.

4  to turn on Quick Spline Mode.  Use the Grid and Status Bar to drop points
at the following approximate locations:

Over 'xpt2' (watch for the cursor to change to )
Directly under 'xpt2' at about Y = -1.9 (negative)
Z = -7.5, Y = -2.5 (negative)
Z = -5.0, Y = -3.0 (negative)
Z = -2.5, Y = -2.7 (negative)
Z = 0, Y = -.9 (negative)
Double click over 'xpt1' to end the B-spline
Return to Select Mode

Your result should resemble Fig. 2.

  Fig. 2

Shape the Curve

1  and  (Top view and Zoom to Fit).

2  or <F7> to turn on Orthogonal Dragging.

3  or Select>Current Layer Filter to turn on the Current Layer Filter.  The
number of the current layer is displayed at the left end of the right side of the
Status Bar, in this case L:1.  Selecting now is restricted to entities on Layer 1 — in
the Available Entities pane, only the five points and B-spline curve are listed (as
well as the default entities). SolidWorks entities come into SurfaceWorks on
layer 0, and new SurfaceWorks entities are placed on layer 1.
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4 Starting at the top, drag point ‘pt5’ to the right about 1.5 units.

5 Continue dragging points to the right, fashioning an hourglass-like profile:

‘pt4’ approximately 4.5 units
‘pt3’ approximately 0.25 unit
‘pt2’ approximately 2.5 units
‘pt1’ approximately 1.0 unit

6 Rotate  so you can see that what you’ve made is a 3D curve (the grid will
disappear).  [This should match distribution model SPOONHOLDER1.sldprt].

Add a Tangency Constraint
We want the 3D B-spline Curve to end normal to the plane in which its endpoints lie
(‘xpl7’). To do this, we’ll use the other two planes we brought in from SolidWorks 
they were created normal to ‘xpl7’. We’ll project the next-to-end points at each end of
the B-spline onto the plane next to it, then replace them with the Projected Points as
the next-to-end control points for the B-spline. The B-spline will then end tangent to
the line between its end and next-to-end points.  This will make it parallel to
'xplane2' which is normal to ‘xpl7’.

1 Remove the Current Layer Only filter and turn off the Grid (which will not
show if you have rotated).

2 Select ‘pt1’ and 'xpt2',  and .

3 Double-click 'curve1' and on the Display tab, turn on the curve’s Polyline.
Notice that the polyline is not perpendicular to 'xpl7' (Fig. 3 Left).

4 Select 'pt1' again and make a >Projected Point or Insert>Point>Projected
Point.

Name = 'pt6'
Point = 'pt1' (pre-selected)
Mirror = 'xplane2'
OK
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    Fig. 3

5 With the new Projected Point (‘pt6’) in the Selection Set, Ctrl+click to add ‘pt1.’

6 <Shift+A> or Tools>Adopt Children, and click the Reverse Order box; OK.
The Projected Point, having adopted all the children of ‘pt1’, is now the second
control point of ‘curve1’ and the curve ends normal to ‘xpl7’ (Fig.3 Right).

Did you notice that part of the polyline disappeared?  Since the polyline runs from
point to point, it is now lined up with 'xplane2' and is no longer visible.

7 Zoom to Fit, then repeat the projection process at the other end of the model,
projecting ‘pt5’ onto ‘xplane1’: Select ‘pt5’, Zoom to Selection (if you want to
see the action up close), F4 to make another Projected Point with Name = 'pt7'
and Mirror = ‘xplane1‘.

8 With ‘pt7’ in the Selection Set, Ctrl+click to add ‘pt5’, Tools>Adopt Children,
Reverse Order, OK. Projected Point ‘pt7’ is now the next-to-last control point of
‘curve1’, and the curve ends normal to ‘xpl7’.

9 Turn off the polyline  for the curve and hide 'xplane1' and 'xplane2'

Make Two Other Control Curves
As you may have guessed, we’re setting ourselves up to make a B-spline Lofted
Surface that ends tangent to each of the two end planes.  To do this we will use three
control curves.  We’ll make these curves by projecting the B-spline Curve we just
created.

Side Trip:  When we loft, it is best to use a single curve in various forms as the lofting
curves.  This will guarantee that the curves all have the same parametric velocity
resulting in a smoother surface shape.  We will use this method again when we
demonstrate the Blend Surface.

Let’s be sure we’re all looking at the same view again:
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1 Return to the Right view , press the right arrow key 7 times and the down
arrow key 3 times and then Zoom to Fit.

2 Select the curve (‘curve1’).

3 >Projected Curve or Insert>Curve>Projected Curve
Name = 'curve2' (default)
Curve = 'curve1' (pre-selected)
Mirror = *X=0 (choose it from the Available Entities pane)
Display>Color = bright red
OK

4 Turn off Point Nametags, , and turn on Curve Nametags, .

5 Select ‘curve1’ again (the B-spline Curve) and use <F4> to make another
Projected Curve:

Name = 'curve3' (default)
Curve = 'curve1' (pre-selected)
Mirror = ‘xpl7’
Color = blue
OK

6 Go to the Front view and confirm that ‘curve2’ (red) lies in X=0 plane.

7 Go to the Right View, and confirm that ‘curve3’ (blue) lies in 'xpl7'.

8 Press the right arrow key 7 times and the down arrow key 3 times and then
Zoom to Fit (Fig. 4).  [This should match distribution model
SPOONHOLDER2.sldprt].

Fig. 4
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Make the Surface
Now we’ll make the surface, using the three control curves we’ve created.

1 Select 'curve3' if it is not still in the Selection Set and Ctrl+click ‘curve1’ and
then ‘curve2’ in that order to add them to the Selection Set.

2 Make a >B-spline Lofted Surface or Insert>Surface>B-spline Lofted
Surface

Name = 'surface1' (default)
Degree = 2
Control curves = (pre-selected)
OK (Fig. 5).

Fig. 5

Recall our discussions about tangency and B-splines. By projecting ‘curve1’ (the next-
to-end control curve) onto the X=0 plane, thus making ‘curve2’ (an end control
curve), we‘ve made the surface’s degree-2 B-spline lofting curves, and thus the
surface itself, end normal to the X=0 plane. Similarly, we’ve made the surface end
normal to the imported plane. We could mirror the surface all the way around and
make a nice peanut...maybe another time.

4 Rotate (keep the mouse button down the entire time, so that you only release it
once) and notice the surface-plane relationships, then return to the Previous view

(  or F8).

5 With ‘surface1’ still in the Selection Set, make a >Mirrored Surface or
Insert>Surface>Mirrored Surface

Name = 'surface2' (default)
Surface = 'surface1' (pre-selected)
Mirror = '*X=0'
OK (Fig. 6).
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Fig. 6

So far, so good. In order to take this back to SolidWorks as a solid, we need to
enclose the volume, then stitch the surfaces together. We can enclose the volume by
adding another B-spline Lofted Surface, between ‘curve3’ and the upper edge of the
Mirrored Surface. We’ll need an Edge Snake on that edge in order to do this.

6 With ‘surface2’ still in the Selection Set, make a >Edge Snake or
Insert>Snake>Edge Snake

Name = 'snake1' (default)
Surface edge = 'v=0'
Surface = 'surface2' (pre-selected)
OK

7 Ctrl+click the blue Projected Curve on the opposite side of the shell (‘curve3’;

projected onto ‘xpl7’), and make a >B-spline Lofted Surface or
Insert>Surface>B-spline Lofted Surface

Name = 'surface3' (default)
Degree = 2
Control curves = (pre-selected)
OK

Now, we’ll specify the stitching:

8 In the Tools>Entity Transfer, , dialog box, in the Stitch buttons, click Set
All to stitch all three surfaces; OK.

9 Return to SolidWorks, saving your changes (Fig. 7). The three stitched
SurfaceWorks surfaces transfer into SolidWorks as an imported solid. This is the
base solid for the model.  [This should match distribution model
SPOONHOLDER3.sldprt].



    Tutorial 6: A Spoon Holder Cut the Side Profile and Make a Flat Bottom

January 14, 2002 SurfaceWorks for SolidWorks Tutorials   •   6-9

    Fig. 7

Cut the Side Profile and Make a Flat Bottom
We have included a sketch (TopCut) that you can use to cut a nice shape for the
upper side profile.

1 Go to the Right view

2 Select 'TopCut', and  or Insert>Cut>Extrude.  OK to accept the defaults
(Through All).

As the model now stands, it wouldn’t stand up  it would roll over. Let’s give it a
flat bottom. Still in Right View:

3 Select 'BottomCut',  or Insert>Cut>Extrude again.  OK to accept the
defaults (Through All) (Fig. 8).

   Fig. 8

Refinements
1 Rotate the model until you can see the bottom, then select the bottom face.

2  or Insert>Features>Fillet/Round. Specify a radius of .3 inch.

Shelling the Model
 Let’s shell the solid:

1 Rotate the part a little, so you can see the upper face, then select the upper face.

2  or Insert>Features>Shell it to a thickness of .1 inch.
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3 Rotate and admire the budding holder.

Final Refinements
1 Return to the Right view so you can see the flat bottom profile, and notice that

the flat-bottom end of the part is at the left and the raised end is at the right (in
this view).

2 Press the down arrow key 4 times.

Any cook will tell you that a spoon in a spoon holder should have its bowl
downward and handle upward (so you don’t get gooey fingers). As you can see by
the location of the flat bottom (at left, in this view) of our spoon holder in
relationship to its bulges, we have it rather backwards — the spoon holder should be
wider at the bottom and narrower at the top.

3 Go back to SurfaceWorks and go to  (Top view).

4 Hide the plane (‘xpl7’), then Zoom to Fit.

5 Turn on Point Nametags and the Grid and Orthogonal Dragging.

6 Drag the control points so that, in this view, the bottom of the hourglass-shape is
wider and the top is narrower (e.g. you could leave the control points at the
following values:

‘pt4’ approximately 2.5 units
‘pt2’ approximately 4.5 units

7 If you’d like, you also can edit the bottom profile curve in Right view.

8 Return to SolidWorks, saving the changes, to see the final spoon holder.

9 Rotate and admire one last time (Fig. 9).



    Tutorial 6: A Spoon Holder Final Refinements

January 14, 2002 SurfaceWorks for SolidWorks Tutorials   •   6-11

    Fig. 9

10 When you've finished examining the results, close the model; don't save changes.
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